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RELEASE NOTES

NI-IMAQ FOR WINDOWS 95/NT
NI-IMAQ for Windows 95/NT is the imaging acquisition software for 
all National Instruments IMAQ devices. The NI-IMAQ software is 
compatible with Windows 95 and Windows NT 4.0 or later.

These release notes describe how to install your NI-IMAQ software. Also 
included is information about upgrading from NI-IMAQ 1.x to 
NI-IMAQ 2.0. Please also see the readme.txt  file included with your 
software for the most up-to-date information about this release of 
NI-IMAQ.

NI-IMAQ Documentation
Your NI-IMAQ software documentation is online. Refer to the About the 
Online Manual Set section later in these notes for more information about 
using the online manuals.

Software Components
Your NI-IMAQ software kit contains the following components:

❑ NI-IMAQ device driver software

❑ NI-IMAQ Microsoft Visual C/C++, Borland, Watcom, and Symantec 
import libraries

❑ NI-IMAQ VIs for G

❑ IMAQ Configuration Utility

❑ Windows 95/NT installer

❑ NI-IMAQ sample code

❑ Online documentation
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Installation Procedures
Insert the NI-IMAQ CD into your drive. An autorun screen will appear, as 
shown in Figure 1. The autorun screen will allow you to install NI-IMAQ, 
install evaluation versions of IMAQ Vision, and view online 
documentation.

Figure 1.  Initial Installer Screen

Click on Install»NI-IMAQ 2.0  to launch the NI-IMAQ 2.0 installer and 
follow the instructions on the installation screens. You must install 
NI-IMAQ before installing your IMAQ hardware device.

Note You must have administrator access in Windows NT to perform the installation.

The Install»IMAQ Vision Evaluation Software  option allows you to 
install evaluation versions of IMAQ Vision for LabVIEW, BridgeVIEW, 
LabWindows/CVI, and ComponentWorks. IMAQ Vision adds high-level 
machine vision and image processing functions to your application 
development environment.
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The View»Release Notes and View»Online Documents options allow you 
to view the online documentation for NI-IMAQ 2.0 and your IMAQ device. 
These documents are provided in Adobe Acrobat portable document 
format (pdf). If you do not have Acrobat Reader installed on your system, 
you will be prompted to install it using the installer provided on the CD.

IMAQ Hardware Configuration
Configure and test your IMAQ hardware by running the IMAQ 
Configuration Utility. Refer to the setup and test document for your device 
and the IMAQ Configuration Utility online help for configuration, 
installation, and testing instructions.

NI-IMAQ 1.x and LabVIEW/BridgeVIEW Compatibility
The NI-IMAQ VIs have changed to increase ease of use and to add more 
functionality. The following changes have been made:

• All VIs now have a IMAQ Refnum In  and IMAQ Refnum Out  
parameter. This is similar to the TaskID input/output used with the 
data acquisition VIs.

• The underscore has been removed from all VI names.

• Low-level acquisition VIs have been added. These VIs add more 
functionality such as asynchronous acquisitions, accessing buffers 
during acquisition, and ring acquisitions.

• Signal I/O VIs have been added. These VIs allow you to control trigger 
lines, generate specific timing pulses, and wait for a hardware event.

High Level VI Changes
IMAQ_Grab is now two VIs—IMAQ Grab Setup and IMAQ Grab 
Acquire. IMAQ Grab Setup starts the grab acquisition. IMAQ Grab 
Acquire returns a copy of the image currently in the buffer. You can use 
IMAQ Close to stop the hardware acquisition.

IMAQ Sequence does not have a mode input, which required that you call 
the VI four times to perform a sequence acquisition. Instead, call IMAQ 
Sequence once to set up the acquisition, perform the acquisition, and return 
the acquired images.

IMAQ_1408 Setup Analog has been removed. IMAQ_1408 Setup Analog 
allowed the white and black reference levels to be set in volts. Use the 
IMAQ Attribute VI to achieve the same functionality. The White 
Reference Level and Black Reference Level attributes in NI-IMAQ 2.0 
are now set in volts instead of steps.
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IMAQ_Snap Async has been removed because the functionality is now 
provided in IMAQ Snap. IMAQ Snap is now asynchronous so that you can 
use it with triggering.

IMAQ_Wait for Event has been changed to IMAQ Wait Signal. The IMAQ 
Wait Signal VI has the same functionality available as IMAQ_Wait for 
Event with additions for the IMAQ PCI-1424.

IMAQ_Trigger Control has been replaced by three VIs. IMAQ Trigger 
Configure configures trigger lines to allow an acquisition to start on a 
trigger. IMAQ Trigger Drive drives a trigger line with a specified signal. 
IMAQ Trigger Read reads the current value of a trigger line.

IMAQ_Trigger RTSI Map has been removed. The mapping of RTSI lines 
is now handled internally by NI-IMAQ. If you specify a RTSI line when 
using the trigger VIs, NI-IMAQ internally maps the RTSI line on the RTSI 
bus to a RTSI trigger line on the IMAQ board.

IMAQ_Info has been removed. The same functionality is available with 
IMAQ Attribute.

IMAQ_Channel has been removed. The acquisition VIs now have a 
channel input which allows you to select a channel on the IMAQ board.

Compatibility VIs
All of the NI-IMAQ 1.5 VIs are available as compatibility VIs. They are 
installed in the vi.lib/addons/imaq  directory; however, they do not 
appear on the imaqview palette. These VIs allow you to load and run 
existing IMAQ applications without changing your code. You should 
replace your NI-IMAQ 1.5 VIs with NI-IMAQ 2.0 VIs at your earliest 
convenience, because the compatibility VIs will not be included in future 
NI-IMAQ releases.

NI-IMAQ provides a tool that will convert some of the NI-IMAQ 1.x VIs 
to 2.0 VIs. Using this tool, you can convert the following VIs:

• IMAQ_Snap to IMAQ Snap

• IMAQ_Snap Async to IMAQ Snap

• IMAQ_Init to IMAQ Init

• IMAQ_Close to IMAQ Close

• IMAQ_Attribute to IMAQ Attribute

• IMAQ_StillColor Attribute to IMAQ StillColor Attribute

• IMAQ_StillColor Setup to IMAQ StillColor Setup
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To use the conversion tool, launch lvimaq.exe , which is located in the 
<ni-imaq>/G compatibility  directory. This will launch a special 
version of LabVIEW that contains the conversion tool. Load your IMAQ 
application. As your application loads, the appropriate NI-IMAQ VIs will 
be converted. After your VI loads, save it. You can now load the VI into 
LabVIEW or BridgeVIEW and convert the VIs that were not converted.

Note This conversion tool will only work with LabVIEW 5.x or BridgeVIEW 2.x VIs. If 
you have an earlier version of LabVIEW or BridgeVIEW, do not use this tool.

The following table describes the corresponding NI-IMAQ 2.0 VI for each 
NI-IMAQ 1.x VI.

Table 1.  NI-IMAQ VI Equivalents

NI-IMAQ 1.x VI NI-IMAQ 2.0

IMAQ_Snap IMAQ Snap

IMAQ_Grab IMAQ Grab Setup, IMAQ Grab 
Acquire

IMAQ_Sequence IMAQ Sequence

IMAQ_Init IMAQ Init

IMAQ_Close IMAQ Close

IMAQ_Attribute IMAQ Attribute

IMAQ_1408 Setup Analog Removed (same functionality is 
available with IMAQ Attribute)

IMAQ_Snap Async Removed (IMAQ Snap provides 
the same functionality)

IMAQ_Wait for event IMAQ Wait Signal

IMAQ_Trigger Control IMAQ Trigger Configure replaces 
starting an acquisition on a trigger

IMAQ Trigger Drive replaces 
driving trigger lines

IMAQ Trigger Read replaces 
reading trigger lines

IMAQ_Trigger RTSI Map Removed (VIs will perform this 
functionality internally)
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NI-IMAQ 1.x and Driver Compatibility
The following changes have been made to the driver.

• Functions

– imgSessionSetTrigger  has been replaced with 
imgSessionTriggerConfigure  and 
imgSessionTriggerDrive.  
imgSessionTriggerConfigure  configures a trigger to start an 
acquisition. ImgSessionTriggerDrive  drives a trigger with a 
specified signal. ImgSessionSetTrigger  is still supported; 
however, you should use the new trigger functions.

– imgSessionSaveBuffer  has been replaced with 
imgSessionSaveBufferEx , which takes a buffer pointer 
instead of a buffer number to determine which buffer to save to 
file.

• Camera attributes

– The camera attributes allow you to control camera functions, such 
as integration time and pixel binning, directly from NI-IMAQ 
with the IMAQ PCI-1424. Consult the Camera Attributes section 
in the NI-IMAQ User Manual for more information.

• Attributes

– IMG_ATTR _WHITE_REF, IMG_ATTR _BLACK_REF, and 
IMG_ATTR_GAIN have been replaced by 
IMG_ATTR_BLACK_REF_VOLT and 
IMG_ATTR_WHITE_REF_VOLT. This allows you to set the 
black and white reference in volts instead of steps.

– IMG_ATTR_LUT is now a session attribute instead of an 
interface attribute.

– IMG_ATTR_FRAME_FIELD is now a session attribute instead 
of an interface attribute.

– IMG_ATTR_INTERFACE_TYPE has been removed.

IMAQ_Info Removed (same functionality is 
available with IMAQ Attribute)

IMAQ_Channel Removed (acquisition VIs now 
have channel input)

Table 1.  NI-IMAQ VI Equivalents (Continued)

NI-IMAQ 1.x VI NI-IMAQ 2.0
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About the Online Manual Set
The complete IMAQ hardware and software documentation set ships with 
your software as Adobe Acrobat portable document format (PDF) files. 
The NI-IMAQ CD includes these files, as follows:

• Setup and Test the IMAQ PCI/PXI-1408

• Setup and Test the IMAQ PCI-1424

• NI-IMAQ Function Reference Manual

• NI-IMAQ User Manual

• NI-IMAQ VI Reference Manual

• IMAQ PCI/PXI-1408 User Manual

• IMAQ PCI-1424 User Manual

• NI-IMAQ 2.0 for Windows 95/NT Release Notes

• IMAQ 2504 Cable Installation Guide

• IMAQ A2514 Cable Installation Guide

• IMAQ D100 Camera Cable Installation Guide

• IMAQ D100100 Cable Installation Guide

• IMAQ D100DAL Cable Installation Guide

• IMAQ Memory Module Installation Guide

To view one of these documents, double-click on the DocList.pdf  file, 
located in the Documents  folder on your NI-IMAQ CD. Click on any 
document name to launch the document you want to view.

Note If you do not already have Acrobat Reader installed on your system, the installer 
will create a new directory, <target install dir>\ACROREAD , and insert the 
Adobe Acrobat Installer into it. Run this installer before viewing your online 
documentation. You must have Acrobat Reader 3.0 or later installed to use the 
online documentation.

Using the NI-IMAQ Online Manual Set
The NI-IMAQ online and pdf software documentation also is installed onto 
your hard drive along with the NI-IMAQ software. 

To view the online help, click the Start button on the taskbar, point to 
Start»Programs»National Instruments IMAQ and choose either 
NI-IMAQ Function Help  or NI-IMAQ VI Help .

To view the pdf documents, click the Start button on the taskbar, point to 
Start»Programs»National Instruments IMAQ»Documentation, and 
choose the appropriate document. This will automatically launch the 



Acrobat Reader and open the selected PDF file. You can assemble your 
own printed manuals by printing either the entire documentation set or only 
the sections relevant to your application.

Click on any entry in the table of contents to jump directly to that page. You 
can jump to major sections within each document quickly and easily by 
clicking on the bookmarks.

When you choose the View»Go To Page... option or are printing pages, 
you must use the page numbers in the lower left corner of the Acrobat 
window, not the number displayed at the bottom center of each manual 
page or listed in the contents and index. The PDF files are electronic 
equivalents of printed manuals. However, unlike printed manuals, the PDF 
file assigns consecutive numbers to each page throughout the document and 
displays this page number. These numbers may not match those shown at 
the bottom center of each manual page.

You can use Acrobat Reader to quickly find and go to every occurrence of 
any word or phrase in the entire document. Simply select the Tools»Find... 
option and type in the key word or phrase you want to find.
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